Feedback on suggested changes for AAAA_Common.xsd and IAB_Acknowledgement.xsd

Mar 15, 2010 at 4:00 PM

Here is DDS feedback on the updates.

Pertaining to the changes to AAAA_Common.xsd saved as AAAA_Common-p.xsd:

  • This  schema is based on an older version of the AAAA_Common.xsd that still uses the old delimiters for the GUID.  The updated version of the schema uses '{' and '}', however we should consider just removing the delimiters for the GUID altogether.  They aren't necessary.
  • The new callbackGUID element is currently set to be optional.  It may be better to make this element required since this value should be available when sending a document.  This way it's consistent and it's clear who the sender is.
  • The new 'callbackGUID' element should be renamed to 'CallbackGUID' with an upper case c to be consistent with the other element names.
  • May also want to consider setting the callbackGUID element datatype to the "guid" datatype rather than "uniqueMsgId".  This is for if  the format of the unqiue message id and the IAB trading partner id were to ever diverge.

Pertaining to the changes IAB_Acknowledgement.xsd saved as IAB_Acknowledgement-p.xsd:

  • Referenced schemas are 'imported' rather than 'included' like the IAB proposal and RFP schemas. Imports are probably better for avoiding errors where multiple elements are included more than once because a base schema is included by more than one schema.  For example, IAB_Proposal,xsd includes both IAB_OrderCommon.xsd  and IAB_ContractCommon.xsd , which both include IAB_BillingCommon,  May want to consider changing IAB RFP and proposal schemas to utilize import rather than include unless include is explicitly needed.




Mar 15, 2010 at 4:24 PM

We also do not have to keep to the AAAA schema since they have discontinued their registry.  We can just write up a new one that better fits our purposes - not to throw a wrench in the works.  We should probably also rename it in the end.

Mar 15, 2010 at 10:20 PM

Also, for the AAAA_Common-p.xsd, the second UniqueMessageID element should be rename to reflect that this value is for the message being acknowledged and not the identifier for the acknowledgement.